Volvo Community Forum. The Forums of the Volvo Owners Club

Forum Rules Volvo Owners Club About VOC Volvo Gallery Links Volvo History Volvo Press
Go Back   Volvo Owners Club Forum > "Technical Topics" > Diesel Engines

Notices

Diesel Engines A forum dedicated to diesel engines fitted to Volvo cars. See the first post in this forum for a list of the diesel engines.

Information
  • VOC Members: There is no login facility using your VOC membership number or the details from page 3 of the club magazine. You need to register in the normal way
  • AOL Customers: Make sure you check the 'Remember me' check box otherwise the AOL system may log you out during the session. This is a known issue with AOL.
  • AOL, Yahoo and Plus.net users. Forum owners such as us are finding that AOL, Yahoo and Plus.net are blocking a lot of email generated from forums. This may mean your registration activation and other emails will not get to you, or they may appear in your spam mailbox

Thread Informations

The 6805 Boost pressure riddle

Views : 608

Replies : 20

Users Viewing This Thread :  

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old May 1st, 2021, 17:52   #1
SushiNinja
New Member
 

Last Online: May 6th, 2021 09:46
Join Date: Mar 2021
Location: Richmond
Default The 6805 Boost pressure riddle

There are more than a few threads already on this forum regarding this issue but we think we have exhausted those options....

My car is a 2005 XC90 D5 AWD with the D5244 engine - so no swirl flaps or resonator box under the engine. We think.

The last couple of months have been dogged by the dreaded Engine Service Required message coming on if, when cold, you accelerate up to approx 2800 revs. This can be temporarily cured by turning the car off, waiting 10 or so seconds and then start it again. You can now drive all day without issue.

What we have discovered is that if you let the engine cool, for example, park it up for 20 or so minutes, the Engine Service Required issue appears when accelerating over approx 2800 revs. If you park it up for less than 15 minutes or so, the issue does not appear when accelerating over 2800 revs.

Plugging it in to our diagnostic (Not Vida), we get the 6805 Boost Pressure Incorrect Flow error logged, which equates to the Volvo code 0244.

What we have done/replaced so far:

Both vacuum mounts replaced as the front one was leaking.
Tested the valve attached to the air filter box - switches around 1000 rpm as it should.
Replaced the control solenoid valve which sits under the crankcase/egr pipework.
Removed and cleaned the egr valve and pipework.
The turbo actuator arm moves freely under a vacuum as it should.
The car has had a new intercooler approx 2000 miles ago by the previous owner.
Replaced the MAP Sensor.
Cleaned the turbo vanes with Wynns Spray Turbo Cleaner.
Checked for collapsing pipes - All seem good.

What is puzzling, is that the issue is so consistent regarding the cooling times and switching off and then restarting. We are fairly confident its a sensor or switch somewhere...... but where?

When we did the Wynns turbo cleaner, the MAF sensor obviously came up as a fault as it was removed to carry out the spray cleaning. This is leading us to think that if it was a MAF issue, surely this would be logged respectively.

We have discounted an air/vacuum leak due to the fact that we can restart the car and its fine all day until it cools for 20 minutes. Surely the leak would be ever present. ??

If it was a turbo vane issue, the same would apply, it would be present all the time.

We have also considered the cat, but then this would also be present all the time.

We must surely be missing something really simple, or we have misunderstood the workshop manual, which I have to say, is rather a mishmash of every volvo model known to man... jeez that thing is confusing.

The other thing we are unsure about, (Because we cannot find any info on it anywhere), is where the hose connects to the turbo on the airbox side, there is a pipe which goes over the top of the engine (Presumably PCV/Evap?) with a sensor/switch inline quite close to the turbo. What is the sensor/switch? We cannot find anything about it. Can this be part of our issue?

Please can someone help two old timers out, that are seriously considering a volvo induced whisky problem
SushiNinja is offline   Reply With Quote
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 00:25.


Powered by vBulletin
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.