View Single Post
Old Oct 14th, 2016, 14:03   #5
RichHodge
New Member
 

Last Online: Oct 14th, 2016 14:06
Join Date: Oct 2016
Location: Milton keynes
Default May help?

Just wanted to help all the people who have had issues with the transmission or weird vibration noises from under the car. I have an XC90 2010. I bought it 6 months ago from a dealer and took out an extended 3 year warranty ( thank god). The car had very low mileage 35,000. Been driven by an old chap to the shops and back.

Anyway about 4 months ago I noticed a weird noise when I got to 5th Gear at 2200 revs. It sounded like a weird vibration noise almost like an exhaust sound/ grating noise. Almost like the noise when you have a hole in your exhaust. My first thought was the catalytic converter going. I took it into the dealer and they said it was an engine mounting and same thing again. At same time the AWD light came up saying not working. It went back in and as the car had been sitting for a few year not doing anything the filters in the Haldex Pump had clogged up.

Finally to car in last week and they had it for a week and have diagnosed the problem as being the drive shaft dampers worn out causing the drive shaft to oscillate at certain revs or between gears. They have just fitted a new drive shaft and dampers kit and it seems to be fixed. Total cost for new prop/ drive shaft plus labour about 600. Warranty covered the lot and now the car seems really responsive. Hopefully that will be the end of it. Hope that helps

Richard
RichHodge is offline   Reply With Quote
The Following User Says Thank You to RichHodge For This Useful Post: